Windows Vista / 7 y servidor SAMBA

14 04 2010

A la hora de acceder a un servidor SAMBA desde un equipo cliente con sistema operativo Windows Vista o Windows 7 se genera un error de acceso, “El inicio de sesión desde esta estación no está autorizado para esta cuenta”. Se comprueban permisos, usuarios y contraseñas, grupo de trabajo o dominio y todo está correcto, pero la conexión sigue siendo rechazada.

El problema radica en la versión de NTLM que utilizan tanto el servidor SAMBA como los clientes Windows, si la implementación de SAMBA es antigua (y no se quiere/puede actualizar por algún motivo) no soporta NTLMv2, y los clientes Windows (en Vista y 7) fuerzan que la negociación para el intercambio de información se haga en NTLMv2, en versiones anteriores como XP primero se intentaba realizar bajo la versión 2, y en caso de que el servidor de ficheros no la soportase se permitía de todas formas la operación.

Bien, para arreglarlo hay que modificar una serie de parámetros en el registro de Windows:

HKLM\System\Current control set\Control\LSA
LMCompatibilityLevel 0x1

HKLM\System\Current control set\Services\LanManWorkstation\Parameters\
RequireSecuritySignature 0x0
EnableSecuritySignature 0x0

Pues eso.





Service Pack 1 para Windows Vista disponible para descargar

16 04 2008

Pocos meses después de la salida al mercado del pésimo Windows Vista, Microsoft publica el primer Service Pack para este Sistema Operativo.

Lee el resto de esta entrada »





vLite, la nueva versión de nLite para Windows Vista

23 02 2008

El nLite, gran utilidad de la que ya hemos escrito por ejemplo para resolver el problema de la instalación de Windows en servidores HP Proliant con la controladora RAID integrada, hasta ahora no servía para usarlo con Windows Vista.

vlite.png

Su autor acaba de sacar el vLite, totalmente compatible ya con Vista.

Lee el resto de esta entrada »